Back to overview
Resolved

Standard Maintenance

Jul 29, 2026 at 6:45pm UTC  –  Jul 29, 2026 at 7:45pm UTC
Affected services
padelmasters.net
admin.padelmasters.net

Resolved
Jul 29, 2026 at 7:45pm UTC

Maintenance ended

Created
Jul 29, 2026 at 6:45pm UTC

Our system was temporarily unavailable for approximately one hour due to a scheduled update. This maintenance was necessary to improve system performance and ensure continued reliability of our services.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding. The page is now fully operational.